summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-10-06 22:36:22 +0200
committerLudovic Courtès <ludo@gnu.org>2013-10-06 22:36:43 +0200
commit17b293a09cee16007816727f8ff77bbd8d0da103 (patch)
tree45a668073affd358f04d66639eab0ab027cf7a76
parentae0c12023d6042801c7cc9d803424452adada50b (diff)
downloadgnu-guix-17b293a09cee16007816727f8ff77bbd8d0da103.tar
gnu-guix-17b293a09cee16007816727f8ff77bbd8d0da103.tar.gz
gnu: Add alsa-utils.
* gnu/packages/linux.scm (alsa-utils): New variable.
-rw-r--r--gnu/packages/linux.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1f9405fee2..e21a019f08 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -32,7 +32,9 @@
#:use-module (gnu packages algebra)
#:use-module ((gnu packages gettext)
#:renamer (symbol-prefix-proc 'g:))
+ #:use-module (gnu packages pulseaudio)
#:use-module (gnu packages attr)
+ #:use-module (gnu packages xml)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu))
@@ -477,6 +479,48 @@ trace of all the system calls made by a another process/program.")
MIDI functionality to the Linux-based operating system.")
(license lgpl2.1+)))
+(define-public alsa-utils
+ (package
+ (name "alsa-utils")
+ (version "1.0.27.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "ftp://ftp.alsa-project.org/pub/utils/alsa-utils-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "1sjjngnq50jv5ilwsb4zys6smifni3bd6fn28gbnhfrg14wsrgq2"))))
+ (build-system gnu-build-system)
+ (arguments
+ ;; XXX: Disable man page creation until we have DocBook.
+ '(#:configure-flags (list "--disable-xmlto"
+ (string-append "--with-udev-rules-dir="
+ (assoc-ref %outputs "out")
+ "/lib/udev/rules.d"))
+ #:phases (alist-cons-before
+ 'install 'pre-install
+ (lambda _
+ ;; Don't try to mkdir /var/lib/alsa.
+ (substitute* "Makefile"
+ (("\\$\\(MKDIR_P\\) .*ASOUND_STATE_DIR.*")
+ "true\n")))
+ %standard-phases)))
+ (inputs
+ `(("libsamplerate" ,libsamplerate)
+ ("ncurses" ,ncurses)
+ ("alsa-lib" ,alsa-lib)
+ ("xmlto" ,xmlto)
+ ("gettext" ,g:gettext)))
+ (home-page "http://www.alsa-project.org/")
+ (synopsis "Utilities for the Advanced Linux Sound Architecture (ALSA)")
+ (description
+ "The Advanced Linux Sound Architecture (ALSA) provides audio and
+MIDI functionality to the Linux-based operating system.")
+
+ ;; This is mostly GPLv2+ but a few files such as 'alsactl.c' are
+ ;; GPLv2-only.
+ (license gpl2)))
+
(define-public iptables
(package
(name "iptables")